Agent App | Network Connectivity Issues
Incident Report for Balto System Status
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 16:37 CDT
Update
We are continuing to investigate this issue.
Posted Mar 20, 2023 - 16:36 CDT
Update
We are now experiencing calls that are failing to start. We are investigating the issue and hope to have this resolved shortly.
Posted Mar 20, 2023 - 12:55 CDT
Investigating
We are currently experiencing a number of Balto Agent Apps that are unable to connect due to firewall changes. Please restart your Agent App to reconect.
Posted Mar 20, 2023 - 10:34 CDT
This incident affected: Balto Agent App, Balto Real-time Coaching, and Balto Real-time Quality Assurance.