Balto Agent | Degraded Performance
Incident Report for Balto System Status
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 15:22 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2023 - 12:56 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 21, 2023 - 09:57 CDT
Investigating
We are experiencing calls that are failing to start sporadically. We are investigating the issue and hope to have this resolved shortly.
Posted Mar 21, 2023 - 08:57 CDT
This incident affected: Balto Agent App.