Agent Login
Incident Report for Balto System Status
Resolved
This incident has been resolved.
Posted Apr 13, 2023 - 19:33 CDT
Monitoring
Issue appears to be resolved, we'll continue to monitor.
Posted Apr 13, 2023 - 19:01 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 13, 2023 - 18:59 CDT
Identified
Agents are unable to login to Balto with their standard credentials. We've identified the root problem and are working to resolve. Stay tuned.
Posted Apr 13, 2023 - 18:55 CDT
This incident affected: Balto Agent App.