Full Outage

Incident Report for Balto System Status

Resolved

The issue has been resolved and we are continuing to monitor.
Posted Mar 27, 2026 - 07:27 CDT

Update

The issue has been resolved and we are continuing to monitor.
Posted Mar 27, 2026 - 07:26 CDT

Investigating

We are currently experiencing a full service outage impacting all users.

Impact: All systems and services are unavailable.

Our engineering team is actively investigating the issue and working to restore service as quickly as possible. We will provide updates as more information becomes available.

We appreciate your patience while we are working to resolve the issues.
Posted Mar 27, 2026 - 07:10 CDT
This incident affected: Balto Agent App, Balto Cloud, Balto Data API, Balto Real-time Coaching, and Balto Real-time Quality Assurance.