Degraded Performance | Agent App
Incident Report for Balto System Status
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 10:37 CST
Update
We are continuing to investigate this issue.
Posted Dec 15, 2021 - 10:37 CST
Investigating
We're aware that some customers are experiencing a delay with Balto connecting to calls. These calls may take up to a few seconds to connect. Our team is aware of this issue and is currently working on a resolution.
Posted Dec 02, 2021 - 13:27 CST
This incident affected: Balto Agent App.