Balto | Degraded Performance

Incident Report for Balto System Status

Resolved

This incident has been resolved.
Posted May 08, 2026 - 21:28 CDT

Update

The fix has been successfully deployed. Both Checklists and Dynamic Prompts are now fully restored and operating as expected
Posted May 08, 2026 - 21:28 CDT

Update

Approximately 90% of requests are processing successfully. We plan to deploy a fix for the remaining 10% this evening at 7pm central time.
Posted May 08, 2026 - 11:51 CDT

Identified

Checklist & Dynamic Prompts relying on our LLM models are not triggering successfully.
Posted May 08, 2026 - 10:32 CDT
This incident affected: Balto Agent App.