Balto | Outage

Incident Report for Balto System Status

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 09:20 CDT

Investigating

We are currently investigating an issue with SSO users being unable to log in to the Balto Agent Application.
Posted Jun 25, 2025 - 09:08 CDT
This incident affected: Balto Agent App.