BaltoCloud Degradation - Quality Dashboard and Agent App Score Tab

Incident Report for Balto System Status

Resolved

We have successfully resolved this issue. Our team will continue to monitor the system closely to ensure ongoing stability. Thank you again for your patience.
Posted May 20, 2026 - 15:17 CDT

Investigating

Our team is currently investigating degradation around the quality dashboard and the scores tab within the agent app. We are working to restore full functionality as quickly as possible and apologize for any inconvenience this may cause.
Posted May 20, 2026 - 11:24 CDT
This incident affected: Balto Cloud.