Checklist Items - Degradation

Incident Report for Balto System Status

Resolved

This incident has been resolved.
Posted Jul 12, 2026 - 12:46 CDT

Update

We are continuing to monitor for any further issues.
Posted Jul 12, 2026 - 12:36 CDT

Monitoring

A fix has been implemented and we are continuing to monitor at this time.
Posted Jul 12, 2026 - 12:36 CDT

Identified

We recently identified an issue affecting the checklist functionality within the desktop agent application. As a result, some checklist items may not have been marked during active calls.
Posted Jul 12, 2026 - 12:19 CDT
This incident affected: Balto Agent App.