Agent App | Outage
Incident Report for Balto System Status
Resolved
This incident has been resolved.
Posted Jul 14, 2022 - 10:08 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2022 - 09:43 CDT
Investigating
We've received reports that Bato Agent application is displaying an error on loading. Our team is aware of this issue and is working on a resolution.
Posted Jul 14, 2022 - 09:29 CDT
This incident affected: Balto Agent App.