Incident on Balto Agent Assist

Incident Report for Balto System Status

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 10:55 CDT

Monitoring

A fix has been implemented and we are currently monitoring the health of the service.
Posted Aug 28, 2026 - 09:29 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 28, 2026 - 09:25 CDT

Investigating

We are currently investigating and issue around the Balto Agent Assist App.
Posted Aug 28, 2026 - 09:17 CDT
This incident affected: Balto Agent Assist.