Outage with the Balto Desktop App
Incident Report for Balto System Status
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 15:33 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 09, 2024 - 15:30 CDT
Investigating
We are currently investigating this issue.
Posted Apr 09, 2024 - 15:21 CDT
This incident affected: Balto Agent App, Balto Real-time Coaching, and Balto Real-time Quality Assurance.