Degradation - Notetaker Service

Incident Report for Balto System Status

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 13:57 CDT

Update

We have applied the fix and will continue to monitor the service.
Posted Aug 27, 2026 - 12:12 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2026 - 12:12 CDT

Identified

We've identified an issue affecting the notetaker service. Notes for calls during this window may be delayed or missing. Once service is fully restored, we'll backfill any affected calls.
Posted Aug 27, 2026 - 11:52 CDT
This incident affected: Balto Agent Assist.