Balto Desktop Outage

Incident Report for Balto System Status

Resolved

This issue has been resolved and we are continuing to monitor.
Posted Jul 01, 2025 - 11:27 CDT

Investigating

We are currently experiencing an issue with the Balto Desktop Application where no new calls are being accepted or successfully established.
Posted Jul 01, 2025 - 11:24 CDT
This incident affected: Balto Agent App.